package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https):\/\/paypal\.me\/.+`)
var str = `http://www.paypal.com
https://paypal.me/sendmerimoneynow?locale.x=en_GB
https://paypal.me/s/fjldj
http://paypal.me/fldjfskj
https://www.paypal.com/us/smarthelp/article/what-is-paypal.me-faq3025`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}