import Foundation
let pattern = #"cheap-flights-to-(\w+[-\w+]*)-[a-zA-Z]{3}-all-routes"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
cheap-flights-to-dubai-dxb-all-routes
cheap-flights-to-sharm-al-sheikh-dxb-all-routes
cheap-flights-to-s-s-dxb-all-routes
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}