$re = '/cheap-flights-to-(\w+[-\w+]*)-[a-zA-Z]{3}-all-routes/i';
$str = 'cheap-flights-to-dubai-dxb-all-routes
cheap-flights-to-sharm-al-sheikh-dxb-all-routes
cheap-flights-to-s-s-dxb-all-routes';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);