import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "cheap-flights-to-(\\w+[-\\w+]*)-[a-zA-Z]{3}-all-routes";
final String string = "cheap-flights-to-dubai-dxb-all-routes\n"
+ "cheap-flights-to-sharm-al-sheikh-dxb-all-routes\n"
+ "cheap-flights-to-s-s-dxb-all-routes";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}