$re = '/Ben/';
$str = 'Hello, my name is Ben. Please visit my website at http://www.forta.com/.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);