const regex = /Ben/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Ben', '')
const str = `Hello, my name is Ben. Please visit my website at http://www.forta.com/.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}