$re = '/(#[\pL_0-9]+)/';
$str = '#tatev #tatev_monastery #tatev_bell #bell';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);