using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#[\pL_0-9]+)";
string input = @"#tatev #tatev_monastery #tatev_bell #bell";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}