package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(#[\pL_0-9]+)`)
var str = `#tatev #tatev_monastery #tatev_bell #bell`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}