#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[A-z]*"
Local $sString = "В истории смсок: ошибка отправки на номер 79066564234 ((от iphoneg2016.qnits.ru, по заказу №217485) Сергей, Реквизиты для оплаты в банке: БИК: 044030774 Банк: "ЮГРА" в г.Санкт-Петербурге Cчет: 40702810202000003601 ООО "Кьюнитс Трейд" ИНН: 7804541370 Назначение: за пересылку заказа №217485 Сумма: 1899 руб): 248: CYRLAT FILTER"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)