# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[A-z]*/ /;t' <<< "В истории смсок: ошибка отправки на номер 79066564234 ((от iphoneg2016.qnits.ru, по заказу №217485) Сергей, Реквизиты для оплаты в банке: БИК: 044030774 Банк: \"ЮГРА\" в г.Санкт-Петербурге Cчет: 40702810202000003601 ООО \"Кьюнитс Трейд\" ИНН: 7804541370 Назначение: за пересылку заказа №217485 Сумма: 1899 руб): 248: CYRLAT FILTER"