const regex = /^((?=3[0-1]|[0-2]\d)\d\d)\.((?=1[0-2]|0[1-9])\d\d)\.\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?=3[0-1]|[0-2]\\d)\\d\\d)\\.((?=1[0-2]|0[1-9])\\d\\d)\\.\\d{4}', 'gm')
const str = `01.01.2009
01-Jan-2009
15.15.2009
05.12.2009
32.01.2009
30.01.2019
35.01.2019`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}