import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?=3[0-1]|[0-2]\\d)\\d\\d)\\.((?=1[0-2]|0[1-9])\\d\\d)\\.\\d{4}";
final String string = "01.01.2009\n"
+ "01-Jan-2009\n"
+ "15.15.2009\n"
+ "05.12.2009\n"
+ "32.01.2009\n"
+ "30.01.2019\n"
+ "35.01.2019";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}