using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?=3[0-1]|[0-2]\d)\d\d)\.((?=1[0-2]|0[1-9])\d\d)\.\d{4}";
string input = @"01.01.2009
01-Jan-2009
15.15.2009
05.12.2009
32.01.2009
30.01.2019
35.01.2019";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}