$re = '/^(\+91|\+91\-|0)?[789]\d{9}$/';
$str = '08500080420';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);