package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\+91|\+91\-|0)?[789]\d{9}$`)
var str = `08500080420`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}