const regex = /^(\+91|\+91\-|0)?[789]\d{9}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+91|\\+91\\-|0)?[789]\\d{9}$', '')
const str = `08500080420`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}