const regex = /(?:account:(.+))(?:site:(.+))(?:zone:(.+))-->|(?:site:(.+))(?:zone:(.+))(?:size:(.+))\s+-->|(?:placement:(.+))-->/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:account:(.+))(?:site:(.+))(?:zone:(.+))-->|(?:site:(.+))(?:zone:(.+))(?:size:(.+))\\s+-->|(?:placement:(.+))-->', 'img')
const str = `<!-- Account: QA 1 Test Site: Video Test Site for Mobile Team (Nitin) Zone: ROS -->
http://optimized-by.rubiconproject.com/a/api/vast.xml?account_id=2763&site_id=40876&zone_id=170462
<!-- Begin Rubicon Project Tag -->
<!-- Site: DOM_TOLIVER_MWEB Zone: Interstitials Size: Mobile Interstitial Landscape -->
<!-- PLACEMENT: Homepage; Above the Fold -->
<script language="JavaScript" type="text/javascript">
rp_account = '8092';
rp_site = '55880';
rp_zonesize = '340088-101';
rp_adtype = 'js';
rp_smartfile = '[SMART FILE URL]';
</script>
<script type="text/javascript" src="http://ads.rubiconproject.com/ad/8092.js"></script>
<!-- End Rubicon Project Tag -->`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}