#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:account:(.+))(?:site:(.+))(?:zone:(.+))-->|(?:site:(.+))(?:zone:(.+))(?:size:(.+))\s+-->|(?:placement:(.+))-->"
Local $sString = "<!-- Account: QA 1 Test Site: Video Test Site for Mobile Team (Nitin) Zone: ROS -->" & @CRLF & _
"http://optimized-by.rubiconproject.com/a/api/vast.xml?account_id=2763&site_id=40876&zone_id=170462 " & @CRLF & _
"" & @CRLF & _
"<!-- Begin Rubicon Project Tag -->" & @CRLF & _
"<!-- Site: DOM_TOLIVER_MWEB Zone: Interstitials Size: Mobile Interstitial Landscape -->" & @CRLF & _
"<!-- PLACEMENT: Homepage; Above the Fold -->" & @CRLF & _
"<script language="JavaScript" type="text/javascript">" & @CRLF & _
"rp_account = '8092';" & @CRLF & _
"rp_site = '55880';" & @CRLF & _
"rp_zonesize = '340088-101';" & @CRLF & _
"rp_adtype = 'js';" & @CRLF & _
"rp_smartfile = '[SMART FILE URL]';" & @CRLF & _
"</script>" & @CRLF & _
"<script type="text/javascript" src="http://ads.rubiconproject.com/ad/8092.js"></script>" & @CRLF & _
"<!-- End Rubicon Project Tag -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")