package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?:account:(.+))(?:site:(.+))(?:zone:(.+))-->|(?:site:(.+))(?:zone:(.+))(?:size:(.+))\s+-->|(?:placement:(.+))-->`)
var str = `<!-- Account: QA 1 Test Site: Video Test Site for Mobile Team (Nitin) Zone: ROS -->
http://optimized-by.rubiconproject.com/a/api/vast.xml?account_id=2763&site_id=40876&zone_id=170462
<!-- Begin Rubicon Project Tag -->
<!-- Site: DOM_TOLIVER_MWEB Zone: Interstitials Size: Mobile Interstitial Landscape -->
<!-- PLACEMENT: Homepage; Above the Fold -->
<script language="JavaScript" type="text/javascript">
rp_account = '8092';
rp_site = '55880';
rp_zonesize = '340088-101';
rp_adtype = 'js';
rp_smartfile = '[SMART FILE URL]';
</script>
<script type="text/javascript" src="http://ads.rubiconproject.com/ad/8092.js"></script>
<!-- End Rubicon Project Tag -->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}