$re = '/^(?<srcNet>\d{1,3}\.\d{1,3}\.\d{1,3}|[0-9a-f]{1,4}:[0-9a-f]{1,4}:[0-9a-f]{1,4}:[0-9a-f]{1,4})[.:]/im';
$str = '218.65.30.30
218.65.30.107
58.218.198.172
2001:468:1900::34
2001:468:4043:6343:1011:6604:3200:2883
::1
2001:0468:1900:1010:4030:3898:3021:aabC
103.3022.349.349
.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);