import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<srcNet>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}|[0-9a-f]{1,4}:[0-9a-f]{1,4}:[0-9a-f]{1,4}:[0-9a-f]{1,4})[.:]";
final String string = "218.65.30.30\n"
+ "218.65.30.107\n"
+ "58.218.198.172\n"
+ "2001:468:1900::34\n"
+ "2001:468:4043:6343:1011:6604:3200:2883\n"
+ "::1\n"
+ "2001:0468:1900:1010:4030:3898:3021:aabC\n"
+ "103.3022.349.349\n"
+ ".1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}