const regex = /^(?<srcNet>\d{1,3}\.\d{1,3}\.\d{1,3}|[0-9a-f]{1,4}:[0-9a-f]{1,4}:[0-9a-f]{1,4}:[0-9a-f]{1,4})[.:]/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<srcNet>\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}|[0-9a-f]{1,4}:[0-9a-f]{1,4}:[0-9a-f]{1,4}:[0-9a-f]{1,4})[.:]', 'gim')
const str = `218.65.30.30
218.65.30.107
58.218.198.172
2001:468:1900::34
2001:468:4043:6343:1011:6604:3200:2883
::1
2001:0468:1900:1010:4030:3898:3021:aabC
103.3022.349.349
.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}