import Foundation
let pattern = #"(\bShe\b)(?:(?!\b(?:she|loves|you)\b).)*(\bloves\b)(?:(?!\b(?:she|loves|you)\b).)*(\byou\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"My she baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it I was lonely once in this great big world Just a nowhere man without a girl 'Till that lucky day when she came my way And she smiled at me as if to say My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it She's the only one, makes me feel so good Can't believe my love so I knock on wood All my silent fears seem to fly away And she smiled at me as if to say Your baby loves loving, my baby loves loving She's got what it takes for me No more lonely nights just waiting for the telephone to ring No more lonely days, my baby's taking care of everything I'm telling you people My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it She's the only one, makes me feel so good Can't believe my love so I knock on wood All my silent fears seem to fly away And she looked at me as if to say"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)