re = /(\bShe\b)(?:(?!\b(?:she|loves|you)\b).)*(\bloves\b)(?:(?!\b(?:she|loves|you)\b).)*(\byou\b)/mi
str = 'My she baby loves loving, my baby loves loving She\'s got what it takes, and she knows how to use it My baby loves loving, my baby loves loving She\'s got what it takes, and she knows how to use it I was lonely once in this great big world Just a nowhere man without a girl \'Till that lucky day when she came my way And she smiled at me as if to say My baby loves loving, my baby loves loving She\'s got what it takes, and she knows how to use it My baby loves loving, my baby loves loving She\'s got what it takes, and she knows how to use it She\'s the only one, makes me feel so good Can\'t believe my love so I knock on wood All my silent fears seem to fly away And she smiled at me as if to say Your baby loves loving, my baby loves loving She\'s got what it takes for me No more lonely nights just waiting for the telephone to ring No more lonely days, my baby\'s taking care of everything I\'m telling you people My baby loves loving, my baby loves loving She\'s got what it takes, and she knows how to use it My baby loves loving, my baby loves loving She\'s got what it takes, and she knows how to use it She\'s the only one, makes me feel so good Can\'t believe my love so I knock on wood All my silent fears seem to fly away And she looked at me as if to say'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end