# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\bShe\b)(?:(?!\b(?:she|loves|you)\b).)*(\bloves\b)(?:(?!\b(?:she|loves|you)\b).)*(\byou\b)"
test_str = "My she baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it I was lonely once in this great big world Just a nowhere man without a girl 'Till that lucky day when she came my way And she smiled at me as if to say My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it She's the only one, makes me feel so good Can't believe my love so I knock on wood All my silent fears seem to fly away And she smiled at me as if to say Your baby loves loving, my baby loves loving She's got what it takes for me No more lonely nights just waiting for the telephone to ring No more lonely days, my baby's taking care of everything I'm telling you people My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it My baby loves loving, my baby loves loving She's got what it takes, and she knows how to use it She's the only one, makes me feel so good Can't believe my love so I knock on wood All my silent fears seem to fly away And she looked at me as if to say"
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.