re = /State: (?P<state>.*)/m
str = 'Name: Test Smith
Email: test@test.com
Phone: 123-456-7890
City: Dallas
State: TX
Zip: 75201'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end