$re = '/State: (?P<state>.*)/m';
$str = 'Name: Test Smith
Email: test@test.com
Phone: 123-456-7890
City: Dallas
State: TX
Zip: 75201';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);