#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)State: (?P<state>.*)"
Local $sString = "Name: Test Smith" & @CRLF & _
"Email: test@test.com" & @CRLF & _
"Phone: 123-456-7890" & @CRLF & _
"City: Dallas" & @CRLF & _
"State: TX" & @CRLF & _
"Zip: 75201"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")