const regex = /^([A-Z0-9a-z_&\+\*\=\(\)\.\%\/\<\>\|\-\?\=\:\,\´\'\&\#\;\sàèìòù]{6,3000})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z0-9a-z_&\\+\\*\\=\\(\\)\\.\\%\\\/\\<\\>\\|\\-\\?\\=\\:\\,\\´\\\'\\&\\#\\;\\sàèìòù]{6,3000})$', '')
const str = `
• esprimere dissensi ovvero effettuare reclami.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}