import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z0-9a-z_&\\+\\*\\=\\(\\)\\.\\%\\/\\<\\>\\|\\-\\?\\=\\:\\,\\´\\'\\&\\#\\;\\sàèìòù]{6,3000})$";
final String string = "\n"
+ "• esprimere dissensi ovvero effettuare reclami.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}