// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Z0-9]{4,5}-[A-Z0-9]{4,5}-[A-Z0-9]{4,5}").unwrap();
let string = "AAA4-AA4A-AAA4
AA44A-A44AA-AA44A
AAA-AAA-AAA
AAA-AAA-AAA
AAA-AAA-AAA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}