using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z0-9]{4,5}-[A-Z0-9]{4,5}-[A-Z0-9]{4,5}";
string input = @"AAA4-AA4A-AAA4
AA44A-A44AA-AA44A
AAA-AAA-AAA
AAA-AAA-AAA
AAA-AAA-AAA";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}