re = /[A-Z0-9]{4,5}-[A-Z0-9]{4,5}-[A-Z0-9]{4,5}/
str = 'AAA4-AA4A-AAA4
AA44A-A44AA-AA44A
AAA-AAA-AAA
AAA-AAA-AAA
AAA-AAA-AAA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end