# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"i18\s*\(\s*['\"](.+)['\"]\,.*\)"
test_str = ("i18('Grant (\\'%s\\') access to ALL users to feature: ', permission.toUpperCase());\n\n"
"alert(i18(\"These users already :\") exist and were:\") ', not added:\") + :\") ) xxx + \"\\n\\n\" + msg ); \n\n"
" var msg;\n"
" if (permission == 'none') {\n"
" msg = i18('This action will remove the rights for \\'%s\\' from feature: ', userName);\n"
" } else if (permission == 'complete') { \n"
" msg = i18('Grant ALL rights for \\'%s\\' to feature: ', userName);\n"
" } else { \n"
" msg = i18('Grant (\\'%s\\') access for \\'%s\\' to feature: ', [permission.toUpperCase(), userName]);\n"
" }")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.