const regex = /i18\s*\(\s*['"](.+)['"]\,.*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('i18\\s*\\(\\s*[\'"](.+)[\'"]\\,.*\\)', 'gm')
const str = `i18('Grant (\\'%s\\') access to ALL users to feature: ', permission.toUpperCase());
alert(i18("These users already :") exist and were:") ', not added:") + :") ) xxx + "\\n\\n" + msg );
var msg;
if (permission == 'none') {
msg = i18('This action will remove the rights for \\'%s\\' from feature: ', userName);
} else if (permission == 'complete') {
msg = i18('Grant ALL rights for \\'%s\\' to feature: ', userName);
} else {
msg = i18('Grant (\\'%s\\') access for \\'%s\\' to feature: ', [permission.toUpperCase(), userName]);
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}