using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"i18\s*\(\s*['""](.+)['""]\,.*\)";
string input = @"i18('Grant (\'%s\') access to ALL users to feature: ', permission.toUpperCase());
alert(i18(""These users already :"") exist and were:"") ', not added:"") + :"") ) xxx + ""\n\n"" + msg );
var msg;
if (permission == 'none') {
msg = i18('This action will remove the rights for \'%s\' from feature: ', userName);
} else if (permission == 'complete') {
msg = i18('Grant ALL rights for \'%s\' to feature: ', userName);
} else {
msg = i18('Grant (\'%s\') access for \'%s\' to feature: ', [permission.toUpperCase(), userName]);
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}