re = /^(?=.{7,15}$)(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[!@#\.,\/\$%\^&\*\(\)\\\-\_=\[\]{}:;"'<>\?]).*$/
str = 'fjk@1Qaa$'
# Print the match result
str.match(re) do |match|
puts match.to_s
end