const regex = /^(?=.{7,15}$)(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[!@#\.,\/\$%\^&\*\(\)\\\-\_=\[\]{}:;"'<>\?]).*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{7,15}$)(?=.*[A-Z])(?=.*[a-z])(?=.*\\d)(?=.*[!@#\\.,\\\/\\$%\\^&\\*\\(\\)\\\\\\-\\_=\\[\\]{}:;"\'<>\\?]).*$', '')
const str = `fjk@1Qaa\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}