$re = '/^(?=.{7,15}$)(?=.*[A-Z])(?=.*[a-z])(?=.*\d)(?=.*[!@#\.,\/\$%\^&\*\(\)\\\\\-\_=\[\]{}:;"\'<>\?]).*$/';
$str = 'fjk@1Qaa$';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);