import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+=[\\w]{0})(?:&|$)";
final String string = "http://localhost:8080/Areas/Country?AreaID=&GroupID=&PlanID=&FromDate=03/07/2016&ToDate=03/08/2016&StatusID=";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}