# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+=[\w]{0})(?:&|$)//g;t' <<< "http://localhost:8080/Areas/Country?AreaID=&GroupID=&PlanID=&FromDate=03/07/2016&ToDate=03/08/2016&StatusID="