re = /https?:\/\/steamcommunity.com\/tradeoffer\/new\/\?partner=(\d+)&token=(.{8})$/
str = 'https://steamcommunity.com/tradeoffer/new/?partner=361738180&token=aDMxWO5R'
# Print the match result
str.match(re) do |match|
puts match.to_s
end