import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/steamcommunity.com\\/tradeoffer\\/new\\/\\?partner=(\\d+)&token=(.{8})$";
final String string = "https://steamcommunity.com/tradeoffer/new/?partner=361738180&token=aDMxWO5R";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}