$re = '/https?:\/\/steamcommunity.com\/tradeoffer\/new\/\?partner=(\d+)&token=(.{8})$/';
$str = 'https://steamcommunity.com/tradeoffer/new/?partner=361738180&token=aDMxWO5R';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);