$re = '/([^_]+$)/';
$str = '-> Total_Business_Units -> TBU000 -> TBU200 -> TBU299 -> TBU201 -> TBU2011';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);