using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^_]+$)";
string input = @"-> Total_Business_Units -> TBU000 -> TBU200 -> TBU299 -> TBU201 -> TBU2011";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}