const regex = /([^_]+$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^_]+$)', '')
const str = `-> Total_Business_Units -> TBU000 -> TBU200 -> TBU299 -> TBU201 -> TBU2011`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}