// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)night (.*)|Total(.*)").unwrap();
let string = "<strong class=\"price scarcity_color sr_gs_rackrate_price
anim_rack_rate
\" title=\"Price for 1 night £69\">
<b>
<span class=\"sr_gs_rackrate_total\">Total: </span>
£69
</b>
</strong>
<td class=\"totalPrice\" colspan=\"3\">
<div data-component=\"track\" data-hash=\"OLNYSRfCbdWGffSRe\" data-stage=\"1\" data-track=\"view\"></div>
Total: £145
</td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}