re = /night (.*)|Total(.*)/mi
str = '<strong class="price scarcity_color sr_gs_rackrate_price
anim_rack_rate
" title="Price for 1 night £69">
<b>
<span class="sr_gs_rackrate_total">Total: </span>
£69
</b>
</strong>
<td class="totalPrice" colspan="3">
<div data-component="track" data-hash="OLNYSRfCbdWGffSRe" data-stage="1" data-track="view"></div>
Total: £145
</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end